Front page slow?
  • glen

    Front page slow?

    by glen » Fri Feb 09, 2007 9:36 am

    I have noticed for the last few weeks that the front page is slow to load, much slower than other much larger front pages hosted at the same place. Is there a coding issue which has been overlooked? Other pages are going at the normal pace, it just always seems to be the front page, sometimes so slow as for me to wonder if the site was down. Is there something on the front page which slows things down?
  • User avatar
    Sir Tristram
    Site Admin
    Site Admin
    Posts: 4350
    Joined: Mon Jul 24, 2006 9:04 pm
    Location: Dundas - NSW
    Contact:

    by Sir Tristram » Fri Feb 09, 2007 9:54 am

    I agree Glen, I have the same thing here on ADSL2+. The front page is very slow to load but once its up the rest of the pages within the site go like a rocket.

    I have logged a support ticket with DREAMHOST about this issue 2 days ago. Maybe it could be a coding thing we'll have to go through some of the Mods that were implemented over the past 2 to 3 weeks.

    JC
    John C.
    **PPOK**
  • glen

    by glen » Fri Feb 09, 2007 10:16 am

    Thanks John, I have the same experience, all other pages are fine, just the front page is slow that is why I thought there may be a funny code on the front page.

    After the good work you did getting on the camera club newsletter, it will be great for people to have a good fast experience when they visit.

    PS congrats on the camera club newsletter
  • User avatar
    Sir Tristram
    Site Admin
    Site Admin
    Posts: 4350
    Joined: Mon Jul 24, 2006 9:04 pm
    Location: Dundas - NSW
    Contact:

    by Sir Tristram » Fri Feb 09, 2007 11:33 am

    Thanks Glen, it concerns me greatly that the front page doesnt load like the rest. Tim has suggested it my be becasue of the large amount of content on the front page and that a browser has to d/l approx 400k of data to load it. That would explain alot I think.

    Now to prove it and fix it.

    JC
    John C.
    **PPOK**
  • User avatar
    myarhidia
    Member
    Member
    Posts: 154
    Joined: Thu Aug 03, 2006 5:11 pm
    Location: Kingsgrove, Sydney, So where the bloody hell are you?
    Contact:

    by myarhidia » Fri Feb 09, 2007 11:58 am

    Just putting something up for thought.

    This forum has grown significantly, the cause of the problem may lie in the SQL requests the front page makes since now there is so much data to process, e.g. the 'last 6 posts' section.
    Does the name Pavlov ring a bell?
    Go Ahead, PP, Hijack, Close, whatever. Life's too short to get upset over minor things. Did you know if I make this font small enough no-one can read it?
  • glen

    by glen » Fri Feb 09, 2007 12:38 pm

    If it is any help, I have just logged in 4 times without the 'last 6 items' showing, still slow. I am guessing it is something like that though.
  • User avatar
    Sir Tristram
    Site Admin
    Site Admin
    Posts: 4350
    Joined: Mon Jul 24, 2006 9:04 pm
    Location: Dundas - NSW
    Contact:

    by Sir Tristram » Fri Feb 09, 2007 12:48 pm

    We turned off the 6 topics thing to test if it was that but clearly it isnt.

    But DREAMHOST have just replied and said that the server the forum is on CPU hits 91% when they open the front page.

    They are now investigating the issue.


    JC
    John C.
    **PPOK**
  • User avatar
    leek
    Reporter
    Reporter
    Posts: 1868
    Joined: Thu Jul 27, 2006 9:20 pm
    Location: Lane Cove, Sydney
    Contact:

    by leek » Fri Feb 09, 2007 1:02 pm

    It may not be anything to do with recent mods... I've always found the front page to be very slow to come up...
    Cheers,
    John
    RB | F! | dA | FB
  • User avatar
    Sir Tristram
    Site Admin
    Site Admin
    Posts: 4350
    Joined: Mon Jul 24, 2006 9:04 pm
    Location: Dundas - NSW
    Contact:

    by Sir Tristram » Fri Feb 09, 2007 1:05 pm

    It may very well be a mod John, dreamhost have found a sql query that is causing this issue.

    Now all we need to do is resolve it.


    JC
    John C.
    **PPOK**
  • User avatar
    Tim
    Reporter
    Reporter
    Posts: 1762
    Joined: Tue Aug 01, 2006 11:31 am
    Location: Gympie, Qld
    Contact:

    by Tim » Fri Feb 09, 2007 2:13 pm

    *Loads shotgun and splatters nasty evil code all over the friggen wall*

    DIE YOU BASTARD!




    Tim
    Come to the Dark Side...... We have COOKIES!

    Digital Still Photographics
    The Fishing Group of Australia
  • User avatar
    Sir Tristram
    Site Admin
    Site Admin
    Posts: 4350
    Joined: Mon Jul 24, 2006 9:04 pm
    Location: Dundas - NSW
    Contact:

    by Sir Tristram » Fri Feb 09, 2007 2:17 pm

    Goes like a ballistic Missile now......



    Thanks very much Tim...



    JC
    John C.
    **PPOK**
  • User avatar
    Bindii
    Cadet
    Cadet
    Posts: 581
    Joined: Thu Jan 11, 2007 11:48 am
    Location: Brisbane Queensland
    Contact:

    by Bindii » Fri Feb 09, 2007 2:18 pm

    Tim wrote:*Loads shotgun and splatters nasty evil code all over the friggen wall*

    DIE YOU BASTARD!

    Tim


    ROTFLMAO

    Stop it! I'm trying to drink my coke!

    *wipes coke from keyboard*
    PP on my images ok
    Posting your own photos in my threads ok :)

    Not all men are annoying. Some are dead.

    www.suekimephotography.com
  • User avatar
    Tim
    Reporter
    Reporter
    Posts: 1762
    Joined: Tue Aug 01, 2006 11:31 am
    Location: Gympie, Qld
    Contact:

    by Tim » Fri Feb 09, 2007 2:19 pm

    Once i knew where the issue was.. it was an easy but dirty fix.. but looks like we got the speed back

    Tim
    Come to the Dark Side...... We have COOKIES!

    Digital Still Photographics
    The Fishing Group of Australia
  • User avatar
    Bindii
    Cadet
    Cadet
    Posts: 581
    Joined: Thu Jan 11, 2007 11:48 am
    Location: Brisbane Queensland
    Contact:

    by Bindii » Fri Feb 09, 2007 2:20 pm

    Tim wrote:Once i knew where the issue was.. it was an easy but dirty fix.. but looks like we got the speed back

    Tim


    Yah!!!! Its sooo much better!!

    I suppose you us to hump you now?

    ;)
    PP on my images ok
    Posting your own photos in my threads ok :)

    Not all men are annoying. Some are dead.

    www.suekimephotography.com
  • User avatar
    Tim
    Reporter
    Reporter
    Posts: 1762
    Joined: Tue Aug 01, 2006 11:31 am
    Location: Gympie, Qld
    Contact:

    by Tim » Fri Feb 09, 2007 2:26 pm

    Bindii wrote:
    Tim wrote:Once i knew where the issue was.. it was an easy but dirty fix.. but looks like we got the speed back

    Tim


    Yah!!!! Its sooo much better!!

    I suppose you us to hump you now?

    ;)


    I'm free after school gets out :lol: :lol: :lol:

    You'll all notice there is something missing on the front page... its under the last topic bar on each forum, it now just displays time and date ... it wont display the last post and who by anymore... I'll try working on it tonight, it was a MySQL glitch causing the severe speed.. and hopefully ill be able to return a very useful feature back to the front page of the forums

    Tim
    Come to the Dark Side...... We have COOKIES!

    Digital Still Photographics
    The Fishing Group of Australia

Who is online

Users browsing this forum: No registered users and 1 guest